2 de febrero de 2008

Nuevo Driver ATI Oficial + Beryl en Debian Etch

Bueno. Este tema ya lo he tocado anteriormente, pero a raíz de un comentario de "Matías" en la guía de instalación del driver Libre Ati, sobre como poder instalar Beryl sobre ésta gráfica, he vuelto a encender mi PC de sobremesa (el pobre, desde que tengo el portátil se encuentra aburrido :D ), el cual tiene una Ati Radeon 9800 Pro 128 Mb, y he instalado el nuevo driver oficial, el cual desde hace ya un tiempo soporta AIGLX, razón por la que antes no era posible utilizar Beryl en Debian Etch con el driver oficial.
Los pasos que he seguido son los siguientes:


1. Accedemos a la web oficial y nos descargamos el driver apropiado a nuestra gráfica:
http://ati.amd.com/support/driver.html

Puedes consular el listado de gráficas soportadas por el nuevo driver en el siguiente enlace:
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_81_linux.html


2. Una vez descargado el archivo (en mi caso he descargado el archivo "ati-driver-installer-8-01-x86.x86_64.run"), nos logueamos en una terminal (KONSOLE) como usuario root, movemos el archivo al directorio de root.
$ su -
password:

# mv /home/nombre_de_tu_usuario/Desktop/ati-driver-installer-8-01-x86.x86_64.run /root


3. En éste PC como tenía instalado el driver oficial anterior, he procedido a desinstalarlo. Lo conveniente sería cerrar la sesión de KDE actual y desde una consola (CTRL + ALT + F1) loguearnos como root y proceder a la desinstalación, pero yo lo he realizado desde una terminal (KONSOLE) con la sesión en marcha y no me ha surgido ningún problema, pero recuerda que lo conveniente es lo 1º.

# aptitude purge fglrx-driver fglrx-kernel-src fglrx-control
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Construir la base de datos de etiquetas... Hecho
Los siguientes paquetes están ROTOS:
fglrx-kernel-2.6.18-4-686 fglrx-kernel-2.6.18-5-686
Los siguientes paquetes no se usan y se ELIMINARÁN:
kernel-package
Se han retenido los siguientes paquetes:
linux-image-2.6-686
Se ELIMINARÁN los siguientes paquetes:
fglrx-control{p} fglrx-driver{p} fglrx-kernel-src{p}
0 paquetes actualizados, 0 nuevos instalados, 4 para eliminar y 1 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 26,7MB.
No se satisfacen las dependencias de los siguientes paquetes:
fglrx-kernel-2.6.18-5-686: Depende: fglrx-driver (= 8.28.8-4) pero no es instalable
fglrx-kernel-2.6.18-4-686: Depende: fglrx-driver (= 8.28.8-4) pero no es instalable
Resolving dependencies...
Las acciones siguientes resolverán estas dependencias

Eliminar los paquetes siguientes:
fglrx-kernel-2.6.18-4-686
fglrx-kernel-2.6.18-5-686

La puntuación es -648

¿Acepta esta solución? [Y/n/q/?] y
Los siguientes paquetes no se usan y se ELIMINARÁN:
kernel-package
Se ELIMINARÁN automáticamente los siguientes paquetes:
fglrx-kernel-2.6.18-4-686 fglrx-kernel-2.6.18-5-686
Se han retenido los siguientes paquetes:
linux-image-2.6-686
Se ELIMINARÁN los siguientes paquetes:
fglrx-control{p} fglrx-driver{p} fglrx-kernel-2.6.18-4-686 fglrx-kernel-2.6.18-5-686 fglrx-kernel-src{p}
0 paquetes actualizados, 0 nuevos instalados, 6 para eliminar y 1 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 27,8MB.
¿Quiere continuar? [Y/n/?] y
Escribiendo información de estado extendido... Hecho
(Leyendo la base de datos ...
122101 ficheros y directorios instalados actualmente.)
Desinstalando fglrx-control ...
(Leyendo la base de datos ...
122092 ficheros y directorios instalados actualmente.)
Desinstalando fglrx-kernel-2.6.18-4-686 ...
Desinstalando fglrx-kernel-2.6.18-5-686 ...
(Leyendo la base de datos ...
122084 ficheros y directorios instalados actualmente.)
Desinstalando fglrx-driver ...
Stopping atieventsd: done.
Eliminando `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL.so.1 by fglrx-driver'
Eliminando `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL.so.1.2 by fglrx-driver'
Purgando ficheros de configuración de fglrx-driver ...
Desinstalando fglrx-kernel-src ...
(Leyendo la base de datos ...
121973 ficheros y directorios instalados actualmente.)
Desinstalando kernel-package ...


4. Una vez desinstalado, preparamos el driver oficial para ser instalado en Debian ETCH, ejecutando el siguiente comando:

Antes de nada, debemos tener éstos paquetes en el sistema. De lo contrario, la construcción del paquete de instalación para Debian Etch fallará.
# aptitude install dpkg-dev debhelper module-assistant

# sh ati-driver-installer-8-01-x86.x86_64.run --buildpkg Debian/etch
Created directory fglrx-install.F12221
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.452.1.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Debian/etch
Package /root/fglrx-driver_8.452.1-1_i386.deb has been successfully generated
Package /root/fglrx-driver-dev_8.452.1-1_i386.deb has been successfully generated
Package /root/fglrx-kernel-src_8.452.1-1_i386.deb has been successfully generated
Package /root/fglrx-amdcccle_8.452.1-1_i386.deb has been successfully generated
Removing temporary directory: fglrx-install.F12221

Como puedes ver, nos ha generado 4 paquetes .deb listos para ser instalados en el sistema y otro archivo con los cambios en el driver.
# ll fglrx-*
-rw-r--r-- 1 root root 5377630 2008-01-31 22:58 fglrx-amdcccle_8.452.1-1_i386.deb
-rw-r--r-- 1 root root 7367324 2008-01-31 22:58 fglrx-driver_8.452.1-1_i386.deb
-rw-r--r-- 1 root root 40168 2008-01-31 22:58 fglrx-driver-dev_8.452.1-1_i386.deb
-rw-r--r-- 1 root root 1080628 2008-01-31 22:58 fglrx-kernel-src_8.452.1-1_i386.deb
-rw-rw-r-- 1 root root 1123 2008-01-31 22:58 fglrx-installer_8.452.1-1_i386.changes

El fichero que nos ha generado con las novedades del nuevo driver, lo renombramos por ejemplo así:
# mv fglrx-installer_8.452.1-1_i386.changes txt-fglrx-installer_8.452.1-1_i386.changes


5. Instalamos los paquetes generados anteriormente y compilamos el driver para la versión del kernel que estamos usando:
# dpkg -i fglrx-*
Seleccionando el paquete fglrx-amdcccle previamente no seleccionado.
(Leyendo la base de datos ...
121740 ficheros y directorios instalados actualmente.)
Desempaquetando fglrx-amdcccle (de fglrx-amdcccle_8.452.1-1_i386.deb) ...
Seleccionando el paquete fglrx-driver previamente no seleccionado.
Desempaquetando fglrx-driver (de fglrx-driver_8.452.1-1_i386.deb) ...
Añadiendo `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL.so.1.2 by fglrx-driver'
Añadiendo `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL.so.1 by fglrx-driver'
Seleccionando el paquete fglrx-driver-dev previamente no seleccionado.
Desempaquetando fglrx-driver-dev (de fglrx-driver-dev_8.452.1-1_i386.deb) ...
Seleccionando el paquete fglrx-kernel-src previamente no seleccionado.
Desempaquetando fglrx-kernel-src (de fglrx-kernel-src_8.452.1-1_i386.deb) ...
Configurando fglrx-amdcccle (8.452.1-1) ...

Configurando fglrx-driver (8.452.1-1) ...
Starting atieventsd: done.

Configurando fglrx-driver-dev (8.452.1-1) ...
Configurando fglrx-kernel-src (8.452.1-1) ...

# cd /usr/src

# module-assistant prepare

# module-assistant build fglrx
Extracting the package tarball, /usr/src/fglrx.tar.bz2, please wait...
Done with /usr/src/fglrx-kernel-2.6.18-5-686_8.452.1-1+2.6.18.dfsg.1-17_i386.deb .

Puedes ver el contenido del nuevo paquete generado, en el cual se puede ver el módulo que tenemos que cargar:
# dpkg -c fglrx-kernel-2.6.18-5-686_8.452.1-1+2.6.18.dfsg.1-17_i386.deb
drwxr-xr-x root/root 0 2008-01-31 23:09 ./
drwxr-xr-x root/root 0 2008-01-31 23:09 ./lib/
drwxr-xr-x root/root 0 2008-01-31 23:09 ./lib/modules/
drwxr-xr-x root/root 0 2008-01-31 23:09 ./lib/modules/2.6.18-5-686/
drwxr-xr-x root/root 0 2008-01-31 23:09 ./lib/modules/2.6.18-5-686/misc/
-rw-r--r-- root/root 1774581 2008-01-31 23:09 ./lib/modules/2.6.18-5-686/misc/fglrx.ko
drwxr-xr-x root/root 0 2008-01-31 23:09 ./usr/
drwxr-xr-x root/root 0 2008-01-31 23:09 ./usr/share/
drwxr-xr-x root/root 0 2008-01-31 23:09 ./usr/share/doc/
drwxr-xr-x root/root 0 2008-01-31 23:09 ./usr/share/doc/fglrx-kernel-2.6.18-5-686/
-rw-r--r-- root/root 10711 2008-01-31 22:58 ./usr/share/doc/fglrx-kernel-2.6.18-5-686/copyright


6. Finalmente, instalamos el módulo en nuestro kernel y preparamos el fichero /etc/X11/xorg.conf para utilizar el nuevo driver:
# module-assistant install fglrx
Seleccionando el paquete fglrx-kernel-2.6.18-5-686 previamente no seleccionado.
(Leyendo la base de datos ...
121875 ficheros y directorios instalados actualmente.)
Desempaquetando fglrx-kernel-2.6.18-5-686 (de .../fglrx-kernel-2.6.18-5-686_8.452.1-1+2.6.18.dfsg.1-17_i386.deb) ...
Configurando fglrx-kernel-2.6.18-5-686 (8.452.1-1+2.6.18.dfsg.1-17) ...

# aticonfig - -initial (son 2 guiones juntos)
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0

# aticonfig –overlay-type=Xv (son 2 guiones juntos)
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-0


7. Cierra la sesión y reinicia el servidor X. (Si tienes dudas de como hacer ésto, puedes ver el post anterior de configuración de la gráfica ATI o simplemente reinicia el equipo). Al reiniciar, inicia sesión con tu usuario, abre una terminal (KONSOLE) y comprueba que tienes aceleración ejecutando el famoso comando:

$ glxinfo | grep direct
direct rendering: Yes

Para que el comando anterior funcione, necesitas tener instalado en el sistema el paquete "mesa-utils". Si no te funciona, probablemente no lo tienes instalados. Ejecuta el siguiente comando para instalarlo:
# aptitude install mesa-utils


8. Una vez llegado aquí y si no ha habido ningún error, solo te queda instalar Beryl. Para ello sigue la guía que publiqué hace unos meses.
http://debiantotal.blogspot.com/2007/04/instalar-beryl-en-debian-etch.html


Saludos y suerte.
Domi - Gran Canaria (Islas Canarias)

44 comentarios:

Hugo H dijo...

Hola Romario, tendrás algún repositorio actualizado para instalar beryl o compiz fusion para Etch??
He seguido las instrucciones del post para instalar Beryl y los repositorios ya no funcionan. Saludos desde Mexico

Romario dijo...

Hola Hugo.
Acabo de comprobarlo y los repositorios siguen activos. Puedes ver los archivos desde este enlace:
http://debian.beryl-project.org/dists/etch/main/

También he hecho una actualización de los repositorios y tampoco me ha dado error:
# aptitude update
...
Des:8 http://debian.beryl-project.org etch/main Sources [3778B]
...

Después instalé:
# aptitude install beryl
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Construir la base de datos de etiquetas... Hecho
Se instalarán automáticamente los siguientes paquetes NUEVOS:
beryl-core beryl-manager beryl-plugins beryl-plugins-data beryl-settings beryl-settings-bindings emerald emerald-themes libberyldecoration0
libberylsettings0 libemeraldengine0 libwnck-common libwnck18 libxres1 python-cairo python-gtk2 python-numeric
Se instalarán los siguiente paquetes NUEVOS:
beryl beryl-core beryl-manager beryl-plugins beryl-plugins-data beryl-settings beryl-settings-bindings emerald emerald-themes libberyldecoration0
libberylsettings0 libemeraldengine0 libwnck-common libwnck18 libxres1 python-cairo python-gtk2 python-numeric
0 paquetes actualizados, 18 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 6474kB/6480kB de ficheros. Después de desempaquetar se usarán 18,8MB.
¿Quiere continuar? [Y/n/?] y
Escribiendo información de estado extendido... Hecho
Des:1 http://ftp.fr.debian.org etch/main python-numeric 24.2-7 [182kB]
Des:2 http://debian.beryl-project.org etch/main libberylsettings0 0.2.0~0beryl1 [42,2kB]
Des:3 http://ftp.fr.debian.org etch/main python-cairo 1.2.0-1 [81,2kB]
Des:4 http://debian.beryl-project.org etch/main beryl-core 0.2.0~0beryl1 [388kB]
Des:5 http://ftp.fr.debian.org etch/main python-gtk2 2.8.6-8 [676kB]
Des:6 http://debian.beryl-project.org etch/main libberyldecoration0 0.2.0~0beryl1 [24,4kB]
Des:7 http://debian.beryl-project.org etch/main beryl-plugins-data 0.2.0~0beryl1 [2356kB]
Des:8 http://debian.beryl-project.org etch/main beryl-plugins 0.2.0~0beryl1 [352kB]
Des:9 http://debian.beryl-project.org etch/main beryl-settings-bindings 0.2.0~0beryl1 [140kB]
Des:10 http://debian.beryl-project.org etch/main beryl-settings 0.2.0~0beryl1 [322kB]
Des:11 http://debian.beryl-project.org etch/main libwnck-common 2.16.3-1 [94,9kB]
Des:12 http://debian.beryl-project.org etch/main libwnck18 2.16.3-1 [126kB]
Des:13 http://debian.beryl-project.org etch/main libemeraldengine0 0.2.0~0beryl1 [79,3kB]
Des:14 http://debian.beryl-project.org etch/main emerald 0.2.0~0beryl1 [209kB]
Des:15 http://debian.beryl-project.org etch/main beryl-manager 0.2.0~0beryl1 [72,6kB]
Des:16 http://debian.beryl-project.org etch/main beryl 0.2.0~0beryl1 [10,6kB]
Des:17 http://debian.beryl-project.org etch/main emerald-themes 0.2.0~0beryl1 [1318kB]
Descargados 6474kB en 1m2s (103kB/s).


Como ves, no he tenido ningún problema. Me ha descargado los paquetes.
Revisa los repositorios, debes haber puesto algo mal.

Saludos.
Domi

Txeli dijo...

Hola Romario.
1º Felicidades por el Blog me ha sido muy útil en mis primeros pasos con debian.

2º Mi duda, consulta, o no se como llamarlo. Empezaré con una descripción del sistema.

El PC es un portatil Acer Aspire 4920 con una ATI radeon HD2400 XT. El sistema es Debian Etch (kernel 2.6.18.6-686. Utilizo Gnome como gestor de ventanas.

Uso los drivers de ATI pero no la última version, sigo paso a paso tu tutorial y consigo instalarlos, consigo aceleración 3D pero... al cerrar sesión se queda la pantalla parpadeando en bandas negras y parte del fondo de escritorio y el PC co mpletamente bloqueado con lo que solo me queda forzar el apagado.

Los únicos drivers que conseguido hacer funcionar son los de la versión 8.42.3 pero en estos no hay manera de hacer correr ni beryl, ni compiz, ni compiz-fusion ni nada parecido.

No tengo ni idea de que es lo que anda o hago mal (seguramente esto último) pero aunque no necesito beryl para nada (lo cierto es que el sistema va muuuyyyyy bien tal y como está) me gustaría probarlo.

Alguna sugerencia?? graciasssssss

Romario dijo...

Hola txeli.
No me ha quedado claro si has conseguido instalar ésta última versión publicada por ATI. En caso afirmativo, ¿has mirado en los logs del sistema en busca de algún posible error?
Investiga en:
/var/log/messages
/var/log/kdm.log ó /var/log/gdm.log
/var/log/Xorg.0.log

Me parece muy raro el error que te da. Hasta ahora nunca me ha pasado nada parecido. Envíame al e-mail del blog tu fichero /etc/X11/xorg.conf para ver si tienes algo raro.

Saludos.
Domi

Matías dijo...

Hola Romario, te agradezco por la entrada, pero antes de hacer nada me quiero sacar una duda, los drivers que tengo yo son los mismos que vos explicas en la instalación con drivers libre?, yo en la otra entrada te deje mi xorg.conf, ya que como te comente tiene unas leves diferencias.
Y otra preguntita, en caso de que no me ande lo de esta guía(que no creo, es más que todo para aprender solamente) como vuelvo al estado anterior? desintalando esto, y reinstalando los drivers libres? o solamente al desinstalar estos me vuelve a lo anterior.

Te pido mil disculpas por ser tan pesado pero estoy aprendiendo.

Desde ya muchas gracias.
Saludos.

Anónimo dijo...

Hola . Felicicades por tu espacio.

estoy intentando la instalacion,y

METAL:~# sh ati-driver-installer-8-01-x86.x86_64.run --buildpkg Debian/etch
Created directory fglrx-install.OI3074
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.452.1.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Debian/etch
./packages/Debian/ati-packager.sh: line 57: dpkg-architecture: command not found
Error: unsupported architecture:
Removing temporary directory: fglrx-install.OI3074

y lo mas curioso es que desde la pagina de Ati, desde el selector de S.O. ya sea Linux o Linux_64, se descarga el mismo driver.

que se os ocurre.. Un saludo.

Anónimo dijo...

mi targeta es Ati Radeon X1300 256MB el equipo dell Dimension E520..

gracias.

Romario dijo...

Hola a todos.
- Matías:
1. En cuanto a la guía del driver Ati libre, las opciones que ves, como comento en el mismo post, debes ir probando y ver cuales te dan mejor rendimiento. Si miras otros comentarios puedes ver recomendaciones de pruebas hechas por otros usuarios.
Los driver "ati" y "radeon" creo que son lo mismo. Recuerdo hacer pruebas activando los 2 y no notaba ninguna diferencia. De ahí deduzco que sean lo mismo. El propietario es el driver "fglrx".

2. Si instalas ésta guía y quieres volver a instalar el driver "libre", debes desinstalar el propietario tal y como explico en el paso 1 de la guía de instalación del driver ATI "Libre". Concretamente, serían éstos paquetes:

# aptitude purge fglrx-amdcccle fglrx-driver fglrx-driver-dev fglrx-kernel-src fglrx-kernel-2.6.18-5-686

El nombre del último paquete puede variar, ya que depende sobre que versión del kernel has compilado el driver. Ver paso 5 de ésta guía.

Una vez hecho ésto, sigue la guía del driver libre (aunque si no desinstalas los paquetes que utilizamos en ella, lo único que necesitaras es cambiar la sección Device del fichero /etc/X11/xorg.conf, la línea Driver "fglrx" por Driver "radeon"

Suerte.


- "Anónimo":
Tu fallo parece tener fácil solución. En principio te falta el paquete dpkg-dev y según un foro de ubuntu que encontré relacionado con tu error, también puedes necesitar el paquete debhelper.
Instala primero el paquete "dpkg-dev"antes de ejecutar el paso 4:
# aptitude install dpkg-dev

Si te sigue dando error, instala el otro paquete:
# aptitude install debhelper

Confírmame si te ha sido necesario instalar 1 ó los 2 paquetes para que te desapareciera el error. Así actualizo la guía con el/los paquete/s necesario/s. Gracias.

Suerte.
Domi

Anónimo dijo...

gracias por tu ayuda. romario
despues de instalar dpkg-dev

METAL:~# sh ati-driver-installer-8-01-x86.x86_64.run --buildpkg Debian/etch
Created directory fglrx-install.Ml3536
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.452.1.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Debian/etch
Package build failed!
Package build utility output:
dpkg-buildpackage: source package is fglrx-installer
dpkg-buildpackage: source version is 8.452.1-1
dpkg-buildpackage: source changed by ATI Technologies Inc. http://ati.amd.com/support/driver.html
dpkg-buildpackage: host architecture i386
dpkg-buildpackage: source version without epoch 8.452.1-1
debian/rules build
dh_testdir
make: dh_testdir: Command not found
make: *** [build] Error 127
Removing temporary directory: fglrx-install.Ml3536

pudo intentar con el segundo paquete..

Un saludo.

Anónimo dijo...

Despues de instalar el segundo paquete.. debhelper

METAL:~# sh ati-driver-installer-8-01-x86.x86_64.run --buildpkg Debian/etch
Created directory fglrx-install.vL3826
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.452.1.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Debian/etch
Package /root/fglrx-driver_8.452.1-1_i386.deb has been successfully generated
Package /root/fglrx-driver-dev_8.452.1-1_i386.deb has been successfully generated
Package /root/fglrx-kernel-src_8.452.1-1_i386.deb has been successfully generated
Package /root/fglrx-amdcccle_8.452.1-1_i386.deb has been successfully generated
Removing temporary directory: fglrx-install.vL3826

parece que a funcionado... voy a terminar la configuracion.
ya te comento..

un saludo.

Anónimo dijo...

por fin.. tofunciona OK.

hizo falta instalar los dos paquetes que comento romario..
gracias por tu ayuda.

un saludo y gracias a todos..

nakano dijo...

Un saludo.
Lo primero decir que soy algo nuevo en esto de linux.
tengo un X1300 en agp e instale debian con kde.
He seguido tu guia para instalar el driver propietario de ati, para ser exactos este "ati-driver-installer-8-01-x86.x86_64.run" supongo que es el mismo para el que has realizado la guia.
No tenia ningun driver de ati instalado, asi que me salte el paso de desinstalacion, por lo demas he seguido la guia al pie de la letra, pero al reiniciar las X pantalla en negro y pc bloqueado, me toca darle al reset y con un poco de suerte el fsck da un fallo y me deja meter la clave de root para mantenimiento y volver a poner el xorg.conf original para poder usar el linux, ya que cada vez que reinicio me sale la pantalla en negro y bloqueo de pc.
No se porque sera, ya he probado de todo lo que se y la verdad es que estoy perdido.
Si me puedes echar un cable te lo agradecere.
Si necesitas que ponga aqui algun archivo de configuracion o log solo dilo y estare encantado.
Muchas gracias de antemano.

Romario dijo...

Hola Nakano.

Puedes volver a poner el xorg que tenías antes de instalar el driver oficial. Fíjate que en el paso 6, al ejecutar el comando "aticonfig --initial" guarda xorg.conf. En la guía me ha generado éste fichero:
Saved back-up to /etc/X11/xorg.conf.original-0

Para solucionar el error que te da actualmente, durante el arranque en el menú de GRUB, selecciona la opción (single-user mode). De ésta manera te entrará en modo texto monousuario. Te pedirá la contraseña de root. Una vez inicies sesión, restaura la copia generada por el comando anterior.

No sé que tal vas de comandos en consola. Te hecho una mano:
login: root
password:

- Guarda el archivo de configuración que produce el error:
# mv /etc/X11/xorg.conf /etc/X11/xorg.conf.ERROR

- Restaura la copia de seguridad:
# cp /etc/X11/xorg.conf.original-0 /etc/X11/xorg.conf

Una vez hecho esto, inicia la sesión con el siguiente comando:
# telinit 2

(si no te funciona, reinicia el equipo con el comando # reboot )

En cuanto al error, investiga en éstos ficheros en busca de algún error (aparecen marcados por las letras (EE) ):
/var/log/messages
/var/log/kdm.log ó /var/log/gdm.log
/var/log/Xorg.0.log

Envíame estos ficheros si quieres, además del xorg.conf que te daba error. Intentaré ver si hay algo raro.

Saludos y suerte.
Domi

nakano dijo...

Un saludo de nuevo.
He hecho una nueva instalación de todo el sistema para probar. Te comento lo que hice paso a paso por si hay algo contraproducente.
Instale debian desde el netinstall "Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21"
solo instalación basica sin escritorio, después instale kde con:
xserver-xorg xfonts-base kde kde-i18n-es kdm
me ponía que tenia 3 paquetes sin actualizar así que también actualicé con apt-get upgrade, uno de ellos era el linux-imagen que tras la actualización me dice que es el mismo que estoy usando así que reinicie nada mas terminar la actualización, mas o menos.
Además modifiqué una config, ya que cuando inicio kde las letras se me ven super enanas y buscando en internet vi que se arreglaba modificando el archivo /etc/kde3/kdm/kdmrc en la linea donde pone "ServerArgslocal=-nolisten tcp" poner "ServerArgslocal=-dpi 75 -nolisten tcp"
También instalé firefox y amsn con el autopakage, para ello necesito instalar tk8.4-dev y bzip2.
una vez hecho todo esto he realizado un ghost del sistema para tener una imagen limpia para pruebas, asi me ahorro volver a instalar desde el principio.
Pase a la instalación del driver siguiendo tu manual desde una Konsole en kde.
Con su me pongo como root y empiezo.
Muevo el driver al directorio root y me voy a ese directorio.
Instalo las dependencias que dices tu en el manual y además instalo gcc y mesa-utils, también instalo libstdc++5 y libstdc++6, lo leí por ahí una vez que se necesitaban (alomejor hice mal al instalarlos, no se)
Después creo los paquetes y los instalo me voy a /usr/src/
Y hago los pasos del module-assistant
Cuando miro el contenido con dpkg -c me sale lo mismo que a ti en el manual.
Hago module-assistant install y listo
Pero en aticonfig --initial me sale esto:
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0
Todo lo hago desde Kde. He dejado el xorg.conf original, a ver si me puedes decir algo. Si quieres puedo hacer pruebas, ya que con la imagen tardo 2 minutos en volver a tener todo bien.
Gracias por todo de nuevo.

Nakanao dijo...

Hola de nuevo, al final conseguí hacer funcionar el driver.
Lo que hice fue no usar aticonfig sino que hice:
#dpkg-reconfigure -phigh xserver-xorg
y elegí el driver fglrx y las resoluciones que queria.
Asi consegui tener aceleracion grafica con el driver propietario de ati.
Ahora he instalado beryl, pero al poco de empezar a usarlo el cubo se me vuelve completamente blanco y no consigo ver nada en el. No se si es que hay algo mal.
lo instale siguiendo tu otra guia.
Si alguno sabe como solucionarlo se lo agradecere.
Un saludo a todos.

Nakano dijo...

Bueno ya he solucionado tambien lo del cubo en blanco con un comentario que habia en la entrada de tu blog sobre la instalacion de beryl.
Este blog me ha sido de mucha ayuda.
muchas gracias por todo y sigue asi, que para los neofitos como yo estas cosas son de gran ayuda.
Un saludo

Matías dijo...

Hola Romario, vuelvo a agradecer por todo lo que nos ayudas y facilitas nuestra vida en linux.
Ahora tengo un problema con el beryl...
Yo ya lo tenía instalado antes con los drivers libres y todo más que bien, ahora le instale estos y me pasa lo mismo que a varios, se pone blanco partes de la pantalla, como las terminales abiertas o el navegador y o la barra de tareas, o el cubo.... etc...
vi que nakano lo soluciono....yo probe varias cosas del los comentarios en beryl y la que mejor me anduvo pero no del todo bien es
http://www.elblogdemaverick.com/?p=12#comment-390
con no del todo bien me refiero que pense que andaba hasta un rato que se repitieron las cosas, no tanto como antes pero si un poco.
si puede el o alguien solucionarme el problema lo agradecería.

Saludos

nakano dijo...

Buenas.
Matías te comento lo que hice yo, se solucionan la mayoría de problemas, pero algunos persisten. De momento el cubo no se me puso blanco ni las ventanas, excepto a veces los navegadores, además de que el navegador va algo lento. Sigo buscando mas soluciones, prueba esta a ver que tal va y lo comentas.
Crea un scrip para arrancar beryl con lo siguiente:

#!/bin/sh
beryl-manager --no-force-window-manager &
beryl --use-copy &

lo haces ejecutable, y desde ahi arrancas beryl
además tengo que renderice mediante copia y he seleccionado aiglx en vez de automático.
A ver que tal te va. Si encuentro algo mas lo comento por aquí.
Un saludo

Matías dijo...

Muchas Gracias Nakano, estoy probando ahora lo que me dijiste, ya en principio una de las ventanas abiertas en blanco... por ahora lo demás todo bien, en breve comento que tal sigue y si encuentro algo también.
Saludos.

Nakano dijo...

Bueno he seguido haciendo pruebas. Por ahora esto es lo que he hecho.
En mi xorg.conf he añadido esto:

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "UseFBDev" "on"
Option "ColorTiling" "on"
Option "EnablePageFlip" "on"
Option "AccelMethod" "EXA" #probar EXA o XAA
Option "XAANoOffscreenPixmaps" "on"
Option "RenderAccel" "on"
Option "allowGLXWithComposite" "on"
Option "AddARGBGLXVisuals" "on"
Option "DisableGLXRootClipping" "on"
EndSection

Y ademas inicio beryl con el siguiente script:

#!/bin/sh
beryl-manager --no-force-window-manager &
LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa beryl --use-copy & #->arranca beryl

Ademas en las opciones de configuracion del diamante tengo seleccionado lo siguinte:

Plataforma de renderizado-> Forzar nvidia.
Renderizado indirecto

Curiosamente con lo de forzar nvidia es cuando mas me esta aguantando, estoy llenandolo de cosas a ver si peta, tengo un video puesto y demas a ver si casca, pero de momento aguanta.
A ver si alguien que tenga el problema del cubo blanco lo prueba.
Un saudo

Nakano dijo...

Saludos de nuevo.
Bueno sigo probando a ver como corrijo el tema del cubo blanco.
Esta es la siguiente prueba que he hecho.
He actualizado el xserver-xorg desdelos repositorios testing y tengo las opciones avanzadas de beryl en automático todas y sigo con mi xorg.conf modificado.
De momento los fallos que tengo son:
Los vídeos dix, xvid, dvd y demás se me ven fatal, si muevo su ventana o el cubo el vídeo se mantiene en el lugar de la pantalla donde estaba, vamos que no se mueve con el resto del escritorio. Los vídeos de youtube se me ven bien sin problemas con los movimientos o al ponerlos en las esquinas del cubo.
Si uso el efecto lluvia pierdo el skydome.
Por lo demás beryl aguanta sin perder ni decorados de ventanas ni se pone blanco nada.
El problema es que al actualizar xserver-xorg desde los repositorios testing me borra algunos paquetes como el build-essential y algunos otros. he buscado como actualizar xorg de otra forma pero no he encontrado nada, seguiée probando cosas.
A ver si alguien puede decir algo sobre esto o probar estos cambios.
Saludos a todos.

ruben dario dijo...

Hola amigos, como muchos otros felicitaciones a Romario por este excelente tutorial.
Bueno, la dificultad mia es que instale debian desde el principio y tube en cuenta todos los pasos, pero cuando abro ATI Catalyst Control Center, me dice en Memory Size que tengo 64 Mb y la tarjeta es de Mb.
La tarjeta es una Radeon X300 SE de 256 Mb

Gracias

ruben dario dijo...

Hola de nuevo, por si falta algo, la tarjeta es PCI Express. (Radeon X300 SE de 256 Mb).

Gracias.

Romario dijo...

Hola Rubén Darío.
No se que puede ser. Quizás no te la detecta bien. Busca en google a ver si encuentras algo.

Saludos.
Domi

Romario dijo...

Nakano.
Gracias por compartir tu experiencia. Puede ser de gran ayuda para otros usuarios.

Saludos y suerte.
Domi

Matías dijo...

Hola a todos, acabo de actualizar la versión del driver por la 8.3 y el beryl sigue con el problema, alguién a encontrado o tiene alguna idea de como solucionarlo??
Romario, nunca probaste instalar el compiz-fusion en el etch??
y estaría bueno que pongas como actualizar los drivers, yo segui practicamente los mismos pasos pero en varios lugarcitos tuve que poner que fuerce instalar o actualizar para que tome los nuevos.
Saludos y gracias.

Anónimo dijo...

Hola, en primero Lugar quiero dar las gracias por esta guía de instalación de la Ati, por un momento creí no poder instalarla jamas, bueno el punto es que la logre instalar pero al hacer la guia del Beryl se instala y todo pero no pasa nada, no carga el escritorio 3d, nada, solo se ve el diamante rojo por el reloj, que podria estar pasando?

Anónimo dijo...

Hola otra vez, también ya modifique las opciones y tal parece que no carga nada de nada!

Gio dijo...

Gio dice: Hola, creo tengo un problema, casi todos los pasos los puedo ejecutar bien, a excepción del último.
Cuando ejecuto glxinfo | grep direct
Me sale el siguiente error:
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: unable to open display (null)
Lo he hecho en dos compus diferentes una con una Ati Radeon 9550 y otra con una Ati Radeon X1300.
Lo extraño es que a pesar de eso, parece que el controlador está funcionando, porque me puedo meter a el Control Center y puedo cambiar las opciones como brillo o la resolución y lo logra hacer. Entonces no entiendo porque me sale el error que cite anteriormente.
Gracias por cualquier ayuda.

Gio dijo...

Hola, soy nuevamente yo.
Ya comprove que efectivamente no me está funcionando el acelerador gráfico, ya que cuando instale beryl, y lo puse a funcionar me funciona por un par de segundos y despues..... CATASTROFE. Todo comienza a comportarce muy extraño y nada funciona.
Por esto les agredesco que me ayuden, porque no entiendo que hago mal sigo paso a paso todos los pasos, lo he hecho dos veces y en dos compus diferentes, obteniendo los mismos resultados.
Gracias

Anónimo dijo...

disculpen q hago despues de:
cpe-0016d405896c:~# sh ati.run --buildpkg Debian/etch
Created directory fglrx-install.KM8894
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.476.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Debian/etch
Package /root/fglrx-driver_8.476-1_amd64.deb has been successfully generated
Package /root/fglrx-driver-dev_8.476-1_amd64.deb has been successfully generated
Package /root/fglrx-kernel-src_8.476-1_amd64.deb has been successfully generated
Package /root/fglrx-amdcccle_8.476-1_amd64.deb has been successfully generated
Removing temporary directory: fglrx-install.KM8894
cpe-0016d405896c:~#

ahi ya no se que hacer.
porfa echenme una mano

MARIANO dijo...

HOLA ROMARIO HE INSTALADO EN MI LAPTOP UNA INSPIRON 8000 LA VERSION ETCH DE DEBIAN HACE 2 DIAS EN EL EVENTO DE FLISOL QUE HUBO AQUI EN MONTEVIDEO, EL TEMA QUE LA RESOLUCION QUE ME DEJA TENER ES SOLO 640X480 Y NO TENGO LA MAS MINIMA IDEA DE COMO SOLUCIONARLO YA QUE SEGUI TUS PASOS, ESTUVE COMO 2 DIAS TRATANDO Y NADA, QUEDO IGUAL.
NO SE QUE MAS HACER, SERA QUE ES UNA MAQUINA MUY VIEJA. P III 900 MHZ.
SALUDOS, MARIANO

Romario dijo...

Hola a todos. Lamento contestar tarde. Últimamente no tengo mucho tiempo para el blog.
- Matías:
Sólo he probado Compiz-Fusion en Debian Lenny (Testing).
Actualizar el Driver es lo que hago en ésta guía. Fíjate en el paso 3. Ahí desinstalamos el driver actual para luego instalar el nuevo.

- Anónimo:
Por los datos que me das, es difícil saber que puede pasar. Revisa los pasos de la guía y compara las salidas con las que te aparecen. Revisa también que tu gráfica está soportada por éste driver.

- Gio:
Parece que el motivo por el que no te funciona ese comando, es porque lo estás ejecutando como usuario "root". Debes ejecutarlo desde una termianl (konsole por ejemplo) con el escritorio iniciado, y siempre con tu usuario.

El error que te da al ejecutar beryl, no se a que puede deberse. Seguro que ya habrás encontrado algo en google. Todavía no me he encontrado con ese error.

- Anónimo:
Lo que debes hacer, es seguir la guía. Tu pregunta no tiene sentido. Por lo que puedo ver, te ha generado los paquetes sin ningún problema.
/root/fglrx-driver_8.476-1_amd64.deb
/root/fglrx-driver-dev_8.476-1_amd64.deb
/root/fglrx-kernel-src_8.476-1_amd64.deb
/root/fglrx-amdcccle_8.476-1_amd64.deb

- Mariano:
No comentas que modelo de gráfica tienes. Lo que debes hacer es instalar el driver correspondiente. Primero deberías mirar si está soportada tu gráfica y si lo está, fijarte en que problema te puede dar. Compara las salidas de los comandos con los que detallo en la guía (para eso están puestas ;-) ).

Te puedo comentar, que yo he tenido Debian instalado en una máquina similar (P III 800 Mhz, 256 Mb RAM, Geforce Mx) y sin ningún problema.

Saludos y suerte.
Domi

Anónimo dijo...

Muchas gracias!!!!
Tu blog me ha sido de gran ayuda :-)

Romario dijo...

De nada. Me alegro que te haya servido de ayuda.

Saludos y suerte.
Domi

[DK] dijo...

Muchas gracias de verdad amigo! Soy demasiado novato en linux, no tengo la mas mínima idea de lo que hice, pero segui tu guía paso a paso y ya me esta funcionando el Beryl inclusive. Mi laptop: IBM Thinkpad T60, ATI Mobility Radeon 1300. Gracias de nuevo, saludos!

Romario dijo...

Hola DK.
De nada ;-) Ahora sólo te queda investigar un poquito mas que es lo que has hecho. No es tan difícil ;-) y como ves, lo tienes detallado.

Saludos y suerte.
Domi

vat69 dijo...

es que tuve que instalar los drivers de ATI, esta fué la más fácil. Es la primer guía completa que veo. Muy buena.

David dijo...

hola que tal, felicidades por tu gran blog me ha sido de gran ayuda para la instalación de debian.

En cuanto a esta entrada todo me ha ido sin problemas hasta el paso 4, donde debe introducirse este comando "ll fglrx-*", pues al introducirlo aparece esto "~# ll fglrx-*
-su: ll: command not found".. que hago mal?

Un cordial saludo

Romario dijo...

Hola David.

ll es un "alias". El comando que realmente se ejecuta es "ls -l". Puedes encontrar mas información en google sobre los alias en linux. También puede ver como activarlos en la entrada en el blog sobre Optimización y Personalización de Debian Etch.

Saludos
Domi

Anónimo dijo...

Hola Romario, solo escribo este corto mensaje para agradecerte esta guía sumamente clara, consisa y bien explicada! También para alentar a quienes tienen duda si esto funcionará, pues si funciona y llega uno al resultado siguiendo todos los pasos ^^

Soy novatón en Debian Etch (en Linux en general!) y apenas hace unos meses que lo uso. En verdad mis respetos Romario, explicas muy bien. Mis felicitaciones desde México ^^

Ora sigo con tu guía para Beryl y allá comentaré como me fue ;) Salu2

METAfaniel dijo...

HEYYY!!! XD No soy usuario anónimo XD Bueno sí pero puse mi nick entre mayor y menor que jeje bueno quizá no debí ponerselos jeje bueno salu2. Ya quiero mi Beryl, se ve muy padre XD Muy buen blog gracias, ya esta en mis favoritos ;)

nike free run 2 dijo...

Cheap Nike free
Nike free run shoes
Nike free run sale
women nike free run sale
Nike Free Run 2

Viagra Online without prescription dijo...
Este comentario ha sido eliminado por un administrador del blog.