26 de mayo de 2007

Instalar Driver Red Inalámbrica Intel PRO/Wireless 3945ABG en Debian Etch

Hace unas semanas me he comprado un portatil ACER, modelo Aspire 5635 WLMI, que incluye una Intel PRO/Wireless 3945ABG como tarjeta de conexión inalámbrica. A continuación detallo los pasos que he seguido para la instalación y configuración.

1. Después de haber instalado Debian Etch según la guía que he publicado en éste blog, nos logueamos en una terminal y procedemos a la instalación del driver, que se encuentra en los repositorios oficiales de Debian Etch.

# aptitude install firmware-ipw3945 ipw3945d ipw3945-modules-$(uname -r)
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Construir la base de datos de etiquetas... Hecho
Se instalarán los siguiente paquetes NUEVOS:
firmware-ipw3945 ipw3945-modules-2.6.18-4-686 ipw3945d
0 paquetes actualizados, 3 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 426kB de ficheros. Después de desempaquetar se usarán 1323kB.
Escribiendo información de estado extendido... Hecho
Des:1 http://ftp.fr.debian.org etch/non-free firmware-ipw3945 0.4 [61,2kB]
Des:2 http://ftp.fr.debian.org etch/contrib ipw3945-modules-2.6.18-4-686 2.6.18+1.1.2-4+etch1 [327kB]
Des:3 http://ftp.fr.debian.org etch/non-free ipw3945d 1.7.22-4 [37,6kB]
Descargados 426kB en 5s (76,0kB/s).
Seleccionando el paquete firmware-ipw3945 previamente no seleccionado.
(Leyendo la base de datos ...
60422 ficheros y directorios instalados actualmente.)
Desempaquetando firmware-ipw3945 (de .../firmware-ipw3945_0.4_all.deb) ...
Seleccionando el paquete ipw3945-modules-2.6.18-4-686 previamente no seleccionado.
Desempaquetando ipw3945-modules-2.6.18-4-686 (de .../ipw3945-modules-2.6.18-4-686_2.6.18+1.1.2-4+etch1_i386.deb) ...
Seleccionando el paquete ipw3945d previamente no seleccionado.
Desempaquetando ipw3945d (de .../ipw3945d_1.7.22-4_i386.deb) ...
Configurando firmware-ipw3945 (0.4) ...
Configurando ipw3945-modules-2.6.18-4-686 (2.6.18+1.1.2-4+etch1) ...

Configurando ipw3945d (1.7.22-4) ...
Starting ipw3945 regulatory daemon: ipw3945d.


2. Cargamos el módulo y comprobamos que está en ejecución:
# modprobe ipw3945
# ps -C ipw3945d
PID TTY TIME CMD
7317 pts/1 00:00:00 ipw3945d


3. Llegado a éste punto, tenemos configurado el driver. Ahora necesitamos configurar la red y para ello voy detallaré 2 formas: una mediante la línea de comandos y otra editando el fichero de configuración de red "/etc/network/interfaces" si queremos que esté disponible en el arranque del equipo.

3.1 LÍNEA DE COMANDOS:
La configuración actual de mi equipo es la siguiente:
# ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::216:d4ff:fed1:5575/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:72629 errors:0 dropped:0 overruns:0 frame:0
TX packets:41694 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:99169422 (94.5 MiB) TX bytes:3970560 (3.7 MiB)
Interrupt:66

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:461 errors:0 dropped:0 overruns:0 frame:0
TX packets:461 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:29919 (29.2 KiB) TX bytes:29919 (29.2 KiB)

# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

Como se puede ver, la IP de mi tarjeta de red eth0 es 192.168.1.100 y la puerta de enlace por donde salgo a internet (mi router/modem) es 192.168.1.1.


- Para ver la interfaz de mi tarjeta de red inalámbrica tecleo lo siguiente:
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

eth1 unassociated ESSID:off/any
Mode:Managed Frequency=nan kHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:16 dBm
Retry limit:15 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:2488 Missed beacon:0


- Ahora buscamos el nombre de la red inalámbrica (SSID):
# iwlist eth1 scan
eth1 Scan completed :
Cell 01 - Address: 00:C0:
ESSID:"USR9106" => Nombre mi Red Inalámbrica
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:off => Tengo la red sin encriptación
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=97/100 Signal level=-28 dBm Noise level=-28 dBm
Extra: Last beacon: 56ms ago


- Si tenemos deshabilitado en el punto de acceso el broadcast del SSID, no te aparecerá en el paso anterior. Una vez que lo tengas, nos conectamos a la red inalámbrica:
# iwconfig eth1 essid "USR9106"

NOTA:
Si tienes activada la encriptación, debes utilizar éste comando poniendo entre comillas tu SSID y clave:
# iwconfig eth1 essid "ESSID_DE_LA_RED" key s:"CLAVE_WEP_EN_ASCII"


- Establecemos la IP de nuestra red Inalámbrica (yo elegí 192.168.1.200):
# ifconfig eth1 192.168.1.200

- Eliminamos la puerta de enlace por defecto, que está asociada a la red eth0.
# route del default gw 192.168.1.1 eth0

Nos quedará así:
# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
localnet * 255.255.255.0 U 0 0 0 eth1

- Añadimos la nueva puerta de enlace asociada a la red inalámbrica eth1.
# route add default gw 192.168.1.1 eth1

# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
localnet * 255.255.255.0 U 0 0 0 eth1
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth1

Comprobamos que todo funciona haciendo un ping al blog:
# ping -c 4 debiantotal.blogspot.com
PING blogspot.l.google.com (72.14.207.191) 56(84) bytes of data.
64 bytes from eh-in-f191.google.com (72.14.207.191): icmp_seq=1 ttl=241 time=193 ms
64 bytes from eh-in-f191.google.com (72.14.207.191): icmp_seq=2 ttl=243 time=179 ms
64 bytes from eh-in-f191.google.com (72.14.207.191): icmp_seq=3 ttl=244 time=179 ms
64 bytes from eh-in-f191.google.com (72.14.207.191): icmp_seq=4 ttl=243 time=189 ms

--- blogspot.l.google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3001ms
rtt min/avg/max/mdev = 179.668/185.572/193.774/6.093 ms

La red ya está configurada. El inconveniente que tiene ésta forma es que al reiniciar perderemos la configuración, con lo que al arrancar, deberemos configurarla de nuevo.

RESÚMEN DE COMANDOS:
Como veo que me ha quedado un poco largo, aquí están resumidos los comandos importantes. Los demás los utilizo para ir mostrando que voy haciendo en cada paso, con sus salidas correspondientes.
# iwconfig eth1 essid "USR9106"
# ifconfig eth1 192.168.1.200
# route del default gw 192.168.1.1 eth0
# route add default gw 192.168.1.1 eth1


3.2 CONFIGURAR FICHERO /etc/network/interfaces:
Si no queremos estar configurando la red en cada inicio, debemos editar el fichero situado en /etc/network/interfaces. El contenido de mi fichero antes de configurar la red inalámbrica es el siguiente:

# cat /etc/network/interfaces
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 194.179.1.100
dns-search pruebas

Como se puede ver, utilizo IP estática en mi red. No utilizo DHCP.

Editamos el fichero y lo dejamos tal y como aparece a continuación.
# vi /etc/network/interfaces
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
#gateway 192.168.1.1
# dns-* options are implemented by the resolvconf package, if installed
#dns-nameservers 194.179.1.100
#dns-search pruebas

# INTERFAZ INALAMBRICA
auto eth1
iface eth1 inet static
address 192.168.1.201
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 194.179.1.100
wireless-essid USR9106
wireless-mode managed

NOTA:
Para adaptarlo a tu red, debes sustituir las direcciones "address, network, netmask, broadcast, gateway y dns-nameservers".

Reiniciamos la red con el comando:
# /etc/init.d/networking restart
Reconfiguring network interfaces...done.

Comprobamos que todo está bien con :
# ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:
inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::216:d4ff:fed1:5575/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:79728 errors:0 dropped:0 overruns:0 frame:0
TX packets:45239 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:102169609 (97.4 MiB) TX bytes:6460431 (6.1 MiB)
Interrupt:66

eth1 Link encap:Ethernet HWaddr 00:19:
inet addr:192.168.1.201 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::219:d2ff:fe09:34d9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:38 errors:46 dropped:3154 overruns:0 frame:0
TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1385208 (1.3 MiB) TX bytes:2433233 (2.3 MiB)
Interrupt:193 Base address:0x4000 Memory:d2100000-d2100fff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:476 errors:0 dropped:0 overruns:0 frame:0
TX packets:476 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:31320 (30.5 KiB) TX bytes:31320 (30.5 KiB)

# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
localnet * 255.255.255.0 U 0 0 0 eth1
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth1

# ping -c 4 debiantotal.blogspot.com
PING blogspot.l.google.com (72.14.207.191) 56(84) bytes of data.
64 bytes from eh-in-f191.google.com (72.14.207.191): icmp_seq=1 ttl=243 time=184 ms
64 bytes from eh-in-f191.google.com (72.14.207.191): icmp_seq=2 ttl=241 time=193 ms
64 bytes from eh-in-f191.google.com (72.14.207.191): icmp_seq=3 ttl=241 time=194 ms
64 bytes from eh-in-f191.google.com (72.14.207.191): icmp_seq=4 ttl=243 time=176 ms

--- blogspot.l.google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3002ms
rtt min/avg/max/mdev = 176.720/187.374/194.368/7.275 ms


4. Para ver el estado de nuestra conexión inalámbrica, tecleamos en una terminal lo siguiente:
$ cat /proc/net/wireless
Inter-| sta-| Quality | Discarded packets | Missed | WE
face | tus | link level noise | nwid crypt frag retry misc | beacon | 20
eth1: 0000 97. 225. 224. 0 0 0 0 2805 0


PENDIENE DE TERMINAR.


FUENTES:
http://ipw3945.sourceforge.net/INSTALL
http://dionisus.cuclug.org.ve/?p=8
$ less /usr/share/doc/wireless-tools/README.Debian

Saludos y suerte.
Domi - Gran Canaria (Islas Canarias)

43 comentarios:

HEDAGRA dijo...

Gracias Debian Total... por este excelente blog de como montar la 3945... Pero tengo una duda, cuando hago el Aptitud install dice ke no se pudo bloquear el /var/lib/dpkg/lock y ke el recurso esta temporalmente suspendido... Entonces se cancela el montaje de los paquetes... Ke puedo hacer al respecto ... GRACIAS

Romario dijo...

Hola. El problema que me comentas suele dar si por ejemplo ya tienes ejecutando aptitude en otra consola, ya se instalando, actualizando el sistema, etc., o por ejemplo si tienes abierto el adept o synaptic.
Si te sigue dando error, comenta que versión estás utilizando y pega aquí la salida del error y el comando que ejecutastes.

Saludos.

HEDAGRA dijo...

Romario... muchas gracias por poner atencion a mi post.... pero ya pude solucionar mi problema el fin de semana ... Reinstale mi kernel y monte de nuevo el ieee y Funciona... mi wireless ya canta jajajaj... Gracias

BellumLeon dijo...

Me sale esto con la primera linea de comandos.

No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "firmware-ipw3945"
No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "ipw3945d"
No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "ipw3945-modules-2.6.18-4-686"
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
Escribiendo información de estado extendido... Hecho

como puedo encontrar esos paquetes o donde los tengo que pones

Romario dijo...

Hola. Creo que tu problema está en que te falta añadir al fichero /etc/apt/source.list el repositorio non-free. Fíjate en el paso 2 del enlace que te adjunto y edita el fichero dejándolo tal y como se muestra ahí.

http://debiantotal.blogspot.com/2007/02/instalacin-debian-etch-40.html

Después actualiza ejecutando el comando:
# aptitude update

Ahora debería dejarte instalar esos paquetes.

Saludos.

Joan dijo...

He seguido el manual y funciona perfectamente salvo en un punto...
Al reiniciar el ordenador no me activa la wireless, tengo que hacer un /etc/init.d/networking restart como root. Si lo hago como usuario normal me da un error. ¿Cuál es el problema?

Gracias.

Romario dijo...

Hola Joan.
No es ningún error que no te deje restaurar la red como usuario normal. Por seguridad, debe ser root el encargado de ésta tarea.
En cuanto a que no te funciona en el inicio, comprueba que tienes ésta línea en el fichero /etc/network/interfaces:
auto eth1

Saludos
Domi

BellumLeon dijo...

La verdad me sirvio mucho.. Gracias! estoy escribiendo esto conectado con mi wifi!

Romario dijo...

Hola BellumLeon. De nada.
Felicidades por la configuración.

Saludos.

DaviZ dijo...

<<<<<< MOVIDO >>>>>>
Hola!

Ya se que esto no toca aqui pero...

Enhorabuena por tu articulo sobre como configurar el chipset 3945 wifi.

Tengo un pequeño problema. He seguido tu manual paso a paso salvo que mi red da DHCP y no consigo conectar. Esta abierta pero con el essid oculto.

Como hago?

En el /etc/network/interfaces he puesto esto
auto eth1
iface eth1 inet dhcp

pero no coge la ip...

Gracias.

DaviZ

1/10/07 19:08

Jeje conozco cual es el essid de mi red.

iwconfig eth1 essid MIRED

Para conectar tambien uso el programa que viene con gnome para las redes.

Romario dijo...

Hola DaviZ.

Aunque tu red te de DHCP, poniendo una dirección del rango de tu red te debería funcionar tal cual está redactada la guía.

Prueba y comenta.

Saludos.
Domi

DaviZ dijo...

Gracias por contestar, lo primero.

Al final lo he solucionado poniendo auto eth1
iface eth1 inet dhcp

y ya coge ip dns y demas por dhcp.

mambo dijo...

hola, ya vi el blog y me parece muy bien explicado salvo una cosa, como hago si tengo que instalar ese paquete sin tener ningun tipo de conexion a internet? en este momento instale dreamlinux en mi laptop y no he podido conectarme a internet.
desde donde puedo bajar los paquetes y de ahi, como los instalo?

Romario dijo...

Hola DaviZ.
Gracias a ti por comentar como lo solucionastes.

Saludos.
Domi

Romario dijo...

Hola Mambo.
La guía la he realizado tomando como base que tienes una Debian Etch instalada en tu sistema. Para instalarla en "dreamlinux" no te puedo ayudar mucho ya que no conozco esa distribución.

Saludos.
Domi

Ivan dijo...

Hola Romario!!

Tengo una inquietud, en la laptop configuro mi WiFi sin problemas, solo tengo una curiosidad, ojala puedas echarme una mano.

No se porque en el monitor de red no me aparecen las señales wifi que detecta, solo la de Ethernet, que debo mover para ver lo que te digo? Espero explicarme bien, mi tarjeta es un atheros.

Saludos!!

pudio dijo...

hola romario mira despues de configurar la tarjeta cuando enpieza a conectarse por dhcp se bloquea el ordenador y tengo que reiniciar a mano , he probado en varias redes y en todas pasa lo mismo ojalatengas la solucion ya que eres un manitas .GRACIAS Y UN SALODO

Romario dijo...

- Hola Iván.
Prueba a instalar éstos paquetes:
# aptitude install knemo kwifimanager

Con Knemo puedes tener en la barra de tareas el icono de las interfaces de red y con Kwifimanager verás el nivel de señal de la red.

Saludos.

- Hola Pudio.
Con tan pocos datos es muy difícil saber que ocurre. No encuentro sentido a que se te bloquee el PC detectando la red por DHCP. Prueba a configurar a mano tal y como explico aquí.

Saludos.

pudio dijo...

hola romario, mira te digo como esta configurado el PC:
Toshiba Tecra A8,Centrino Duo a 1662, 1 GRAM y wifi Intel IPW3945ABG y el problema es el siguient:Cuando empieza ha conectarse de repente se bloquea todo el ordenador y tengo que reiniciarlo a mano , por que no funciona ningun boton ni tampoco el raton y a veces en el inicio se cuelga tambien.Bueno espero que con esto sea suficiente. Un saludo y GRACIAS POR TU ATENCION

Romario dijo...

Hola Pudio.

Haz probado a configurar la red de forma manual? ¿te pasa lo mismo?

Saludos.
Domi

Lex dijo...

Hola! Sigo todos los pasos pero me aparece lo siguiente

# /etc/init.d/ipw3945d restart
* Stopping ipw3945 regulatory daemon ipw3945d [ ok ]
* Not starting ipw3945 regulatory daemon, driver not loaded.

Estoy desesperado!! No puedo hacer arrancar la placa desde hace tiempo! Por favor me das una mano?

Lex dijo...

Ya lo solucione gracias!!!
Muy buen tutorial, en este momento estoy desde Debian usando mi ipw3945.

Anónimo dijo...

Te anexo mi archivo "interfaces" y abajo te comento lo que necesito:


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth1
iface eth1 inet dhcp

# Red Inalambrica "Departamento"
auto eth2
iface eth2 inet dhcp
wireless_essid 2WIRE854
wireless_channel 10
wireless_mode managed
wireless_keymode open
wireless_key1 2794333137
wireless_key2 s:millaveascii
wireless_defaultkey 1

# Red Inalambrica "Hogar"
#auto eth2
#iface eth2 inet dhcp
# wireless_essid 2WIRE267
# wireless_channel 6
# wireless_mode managed
# wireless_keymode open
# wireless_key1 2933799558
# wireless_key2 s:millaveascii
# wireless_defaultkey 1


Como podras ver, tengo dos redes inalambricas, una en mi departamento y otra en mi casa. El problema es que cada que cambio de lugar tengo que iniciar la laptop y modificar este archivo, agregando "#" antes de cada linea que no corresponda a la red que me interesa y eliminandolos de aquella que si ocupo.

Conoces algún programa o alguna manera de hacer que linux detecte cual red de estas dos esta disponilbe y la active automaticamente, tal como lo hace Windows =(

jorge dijo...

He seguido este manual para configu-
rar una tarjeta inalambrica lynksys
WMP55AG sin exito!
esto es lo que logrado configurar

iwlist ath0 scan

ath0 Scan completed :
Cell 01 - Address: 00:16:B6:0D:71:1A
ESSID:"linksys_SES_32269"
Mode:Master
Frequency:2.437 GHz (Channel 6)
Quality=26/94 Signal level=-69 dBm Noise level=-95 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

y este es mi interfaces

auto lo
iface lo inet loopback
auto ath0
iface ath0 inet static
address 192.168.1.1
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.12
wireless-mode master
wireless-essid linksys_SES_32269
wireless-key s:ba06ema9zce9fqii
no tengo conexion con ping 0 received
algun tip o sugerencia
gracias de antemano

Romario dijo...

Hola a todos.
- Lex. Me alegro que al final lo arreglaras. Podrías comentar cual fue el error. Podría ser útil para alguien mas.

- Anónimo:
Prueba a instalar éste paquete:
# aptitude install knetworkconf

Luego vete al CENTRO DE CONTROL / INTERNET Y RED / PARÁMETROS DE RED
Desde esa ventana, puedes ver una pestaña que pone PERFILES DE RED. Creo que es lo que andas buscando. Todavía no he tenido la oportunidad de probarlo. Si lo consigues te agradecería que comentaras como te fue.

- Jorge:
Instala éste paquete e intenta configurarlo a ver si tienes más suerte:
# aptitude install wlassistant

Puedes encontrar el ejecutable en:
MENÚ KDE / INTERNET / WIRELESS ASSISTANT

Supongo que tienes bien configurado el driver de tu tarjeta inalámbrica. Podría ser ese el problema.

Saludos.
Domi

jorge dijo...

Antes que nada Gracias!

realmente soy un novato en esto

Creo que tengo el driver mal configurado madwifi ( linksys WMP55AG pci)

cuando reinicio la network este es el error que da;

Reconfiguring network interfaces...Error for wireless request "Set Mode" (8B06) :
SET failed on device ath0 ; Invalid argument.
Error for wireless request "Set Mode" (8B06) :
SET failed on device ath0 ; Invalid argument.
Error for wireless request "Set Encode" (8B2A) :
invalid argument "ba06ema9zce9fqii".
done.

algun comentario!!!

n_r_gy dijo...

Lex, me podrias decir como lo has hecho para solucionar el problema de "driver not loaded", pq tengo el mismo problema.

Muchas gracias!

Por cierto, los tutoriales de instalacion de debian y este, perfectos!!!

Cristian Ortiz M. dijo...

no me aparece la eth1 ni nada por el estilo solo la lo y la eth0 que es la tarjeta de rj45. Todo esta tal cual hasta el iwconfig y sale estonada mas:
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Lex dijo...

Lo que yo hice fue bajarme los modulos del kernel y instalar los que eran compatibles con la placa. Son los 2.6.18.5-686 Y despues via synaptic instale los 3 archivos que nombra el tutorial. Espero que les sirva. Saludos.

Cristian Ortiz M. dijo...

yo tengo debian "testing" y realize todo lo que dice la guia con repositorios de "testing". Sera el problema del "testing"? tienes repositorios para bajar el 2.6.18.5-686 en "testing"?

Romario dijo...

Hola. Lamento contestar tan tarde, pero es que llevo unos meses muy liado.

Jorge:
Espero que lo hayas solucionado. Te sugiero que busques la cadena de error en google, ya que no se que puede sucederte.

Cristian:
La guía la he redactado para Debian Etch, pero creo que en Lenny (testing) debería funcinar también. Puede que algún paquete haya cambiado de nombre.
En cuanto al kernel, tienes que realizarlo con la versión que viene en Testing. Fíjate que en la guía utilizo ésta línea a la hora de instalar el siguiente paquete:
ipw3945-modules-$(uname -r)

El $(comando) es una forma de utilizar la salida de un comando en otra sentencia. Si ejecutas "uname -r" te muestra el kernel que tienes en el sistema, con lo que si unes cabos, verás que debería funcionarte independientemente de la versión del kernel que tengas.

También puedes ver que paquetes que tienes disponibles en testing para ésta tarjeta inalámbrica con el siguiente comando:

# aptitude search ipw3945

Bueno, espero que hayas entendido algo.

¿estás seguro que tienes ésta tarjeta inalámbrica? Ejecuta el siguiente comando. Deberías ver algo similar:

# lspci | grep 3945
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Saludos y suerte.
Domi

Anónimo dijo...

Quisiera que porfavor me ayuden, el problema es que cuando intento conectarme a una red inalambrica, la maquina se queda congelada y no responde para nada, ya intente de varias maneras y no he podido conectarme, he seguido todos los pasos del blog pero sigue sin conectar.
Mi maquina es una pavilion dv6426us con la tarjeta intel 3945ABG, tengo debian etch.
Cualquier respuesta se los agradeceria mucho.

Romario dijo...

Hola "Anónimo".
Intenta arrancando un CD de UBUNTU 7.04, 7.10 y ver si te reconoce y configura la red inalámbrica, para así descartar que no es un error de hardware.

Saludos y suerte.
Domi

Anónimo dijo...

Gracias "Romario" por tu ayuda, ya he solucionado el problema, lo hice configurando la Wi-Fi manualmente, esto lo escribi conectado con mi Wi-Fi.

Romario dijo...

Enhorabuena amigo ;-) Me alegro que lo hayas conseguido.

Saludos.
Domi

ZoeDoGaM dijo...

(Leyendo la base de datos ...
121770 ficheros y directorios instalados actualmente.)
Desempaquetando firmware-ipw3945 (de .../firmware-ipw3945_0.4_all.deb) ...
Seleccionando el paquete ipw3945-modules-2.6.18-6-686 previamente no seleccionado.
Desempaquetando ipw3945-modules-2.6.18-6-686 (de .../ipw3945-modules-2.6.18-6-686_2.6.18+1.1.2-4+etch3_i386.deb) ...
Seleccionando el paquete ipw3945d previamente no seleccionado.
Desempaquetando ipw3945d (de .../ipw3945d_1.7.22-4_i386.deb) ...
Configurando firmware-ipw3945 (0.4) ...
Configurando ipw3945-modules-2.6.18-6-686 (2.6.18+1.1.2-4+etch3) ...

Configurando ipw3945d (1.7.22-4) ...
* Not starting ipw3945 regulatory daemon, driver not loaded.

Yo sigo con ese problema :(
Si que tengo una IPW3945.
Ya no sé cómo hacer que funcione :(
Saludos.

Anónimo dijo...

Primero que todo es demasiado bueno el blog... ahora, instalé lenny en una dell vostro 1510, no ha tenido ningun problema, salvo la red alambrica que no me permite conectarme a internet, para inalambrica no tuve problemas, la tarjeta es una Realtek 8169. Utilice el pppoeconf y me aparecio que el concentrador de acceso no respondio.

Si alguien supiera que hacer se lo agradeceria.

Saludos.

Anónimo dijo...

He seguido todos los pasos como indicas sin ningún problema hasta que trato de hacer la conexión. Cuando trato de conectarme a mi red me pide la contraseña pero no consigue conectar. Tengo una pequeña red con cuatro equipos, los windows conectan sin problema y el debian la tarjeta de red LAN tambien. MUCHAS GRACIAS.

Anónimo dijo...

Hola intento seguir la guia pero usando lenny y me instale: firmware-iwlwifi.
Entonces sigo los pasos, miren:
#modprobe iwl3945
#ps -C iwl3945
PID TTY TIME CMD
1926 ? 00:00:00 iwl3945

#ifconfig
eth1 Link encap:xxxxxxxxx
xxxxxxxxx xxxxxxxxx
.
.
.
xxxxxxxxx

#route
Kernel IP routing table
--Destination
192.168.1.9
default
--Gateway
*
home
--Use Iface
eth1
eth1
//entre otras cosas

#iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11 ESSID
.
.
.
xxxxxxxxxxxxxxx

----------------------------
#iwlist eth1 scan
eth1 Interface doesn't support scanning
#iwlist eth0 scan
eth0 Interface doesn't support scanning
----------------------------
#iwlist wlan0 scan
wlan0 Interface doesn't support scanning : Network is down

y pues hasta ahi llego.
Alguien que pueda darme una mano porfavor.

Gracias.

Anónimo dijo...

# /etc/init.d/ipw3945d restart
* Stopping ipw3945 regulatory daemon ipw3945d [ ok ]
* Not starting ipw3945 regulatory daemon, driver not loaded.

Ya no se que hacer , me dice que estan cargados los modulos pero no me arranca demonio que hago

Chuky dijo...

A ver, yo como he solucionado lo del ipw3945 ha sido instalando los modulos del kernel 2.6.18-6-686 y arrancando con ese kernel. Funciona perfectamente.
Si no te funciona así prueba a cargar el modulo a mano.

$ modprobe ipw3945

Y luego lanza el demonio, espero que te sea de ayuda. Un saludo

replica louis vuitton bags dijo...

fake louis vuitton bags for sale.
cheap louis vuitton antheia for sale.
replica Mahina Leather for sale.
replica Monogram Canvas handbags for sale.
replica Monogram denim handbags for sale.

Viagra Online without prescription dijo...
Este comentario ha sido eliminado por un administrador del blog.