13 de mayo de 2007

Instalar Adobe Reader 7.09 en Debian Etch

Hola. Después de mas de un mes sin poder actualizar el blog, a continuación explico los pasos para instalar Adobe Reader que actualmente va por la versión 7.09 en Debian Etch.

ACTUALIZACIÓN 18.09.07:
Publicada una nueva guía para instalar la versión de Adobe Reader 8.1 en Debian Etch.

1. Descargamos la versión RPM del paquete de la siguiente dirección:
http://www.adobe.com/es/products/acrobat/readstep2.html


2. Mientras se descarga, abrimos una terminal, nos logueamos como "root" e instalamos alien, que nos permite convertir paquetes de .rpm (Red Hat) en .deb (Debian).
$ su -
password:

# aptitude install alien
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Construir la base de datos de etiquetas... Hecho
Se instalarán automáticamente los siguientes paquetes NUEVOS:
libbeecrypt6 libneon25 librpm4 rpm
Se instalarán los siguiente paquetes NUEVOS:
alien libbeecrypt6 libneon25 librpm4 rpm
0 paquetes actualizados, 5 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 2120kB de ficheros. Después de desempaquetar se usarán 6590kB.
¿Quiere continuar? [Y/n/?] y
Escribiendo información de estado extendido... Hecho
Des:1 http://ftp.fr.debian.org etch/main libbeecrypt6 4.1.2-6 [108kB]
Des:2 http://ftp.fr.debian.org etch/main libneon25 0.25.5.dfsg-6 [101kB]
Des:3 http://ftp.fr.debian.org etch/main librpm4 4.4.1-13 [978kB]
Des:4 http://ftp.fr.debian.org etch/main rpm 4.4.1-13 [830kB]
Des:5 http://ftp.fr.debian.org etch/main alien 8.64 [104kB]
Descargados 2120kB en 49s (42,4kB/s).
Seleccionando el paquete libbeecrypt6 previamente no seleccionado.
(Leyendo la base de datos ...
72196 ficheros y directorios instalados actualmente.)
Desempaquetando libbeecrypt6 (de .../libbeecrypt6_4.1.2-6_i386.deb) ...
Seleccionando el paquete libneon25 previamente no seleccionado.
Desempaquetando libneon25 (de .../libneon25_0.25.5.dfsg-6_i386.deb) ...
Seleccionando el paquete librpm4 previamente no seleccionado.
Desempaquetando librpm4 (de .../librpm4_4.4.1-13_i386.deb) ...
Seleccionando el paquete rpm previamente no seleccionado.
Desempaquetando rpm (de .../archives/rpm_4.4.1-13_i386.deb) ...
Seleccionando el paquete alien previamente no seleccionado.
Desempaquetando alien (de .../archives/alien_8.64_all.deb) ...
Configurando libbeecrypt6 (4.1.2-6) ...

Configurando libneon25 (0.25.5.dfsg-6) ...

Configurando librpm4 (4.4.1-13) ...

Configurando rpm (4.4.1-13) ...

Configurando alien (8.64) ...


3. Accedemos al directorio de nuestro usuario local en el que se ha descargado el paquete y lo convertimos:
# cd ~nombre_usuario/Desktop
# ls -l
-rw-r--r-- 1 domi domi 47978347 2007-05-13 07:13 AdobeReader_esp-7.0.9-1.i386.rpm

# alien --script AdobeReader_esp-7.0.9-1.i386.rpm
adobereader-esp_7.0.9-2_i386.deb generated


4. Procedemos a instalarlo:
# dpkg -i adobereader-esp_7.0.9-2_i386.deb
Seleccionando el paquete adobereader-esp previamente no seleccionado.
(Leyendo la base de datos ...
72457 ficheros y directorios instalados actualmente.)
Desempaquetando adobereader-esp (de adobereader-esp_7.0.9-2_i386.deb) ...
Configurando adobereader-esp (7.0.9-2) ...
ln: creando el enlace simbólico «/Reader/intellinux/lib/libldap.so» a «/usr/lib/libldap.so.2»: No existe el fichero o el directorio
ln: creando el enlace simbólico «/Reader/intellinux/lib/liblber.so» a «/usr/lib/liblber.so.2»: No existe el fichero o el directorio
dpkg: error al procesar adobereader-esp (--install):
el subproceso post-installation script devolvió el código de salida de error 1
Se encontraron errores al procesar:
adobereader-esp

Como se puede ver, me dió un error al enlazar una librería necesaria para el programa. De todas formas, a mi me ha funcionado sin corregir éste error. Pero bueno, para evitar algún posible fallo, lo creamos a mano de la siguiente forma:

# cd /usr/local/Adobe/Acrobat7.0/Reader/intellinux/lib/
# ln -s /usr/lib/libldap.so.2

NOTA:
He visto que debido a éste error, el paquete se queda en estado "half-configured" que según "man dpkg" nos dice lo siguiente; "The package is unpacked and configuration has been started, but not yet completed for some reason.". La consecuencia que tiene ésto es que cada vez que instalo algo o actualizo, intenta configurar de nuevo el paquete.
Ya que el paquete funciona perfectamente, pues corrijo los errores manualmente, la solución que he encontrado es editar el estado del paquete en la base de datos de instalación. Para ello hacemos:

¡¡OJO, MUCHO CUIDADO CON ESTE ARCHIVO QUE CONTIENE EL HISTORIAL DE PAQUETES DEL SISTEMA!! HACED COPIA DE SEGURIDAD
# cp /var/lib/dpkg/status /root

# vi /var/lib/dpkg/status
Una vez dentro, escribimos en la línea de comandos de VI lo siguiente:
/adobereader

Nos aparecerá lo siguiente:
Package: adobereader-esp
Status: install ok half-configured - MODIFICAR
Priority: extra
Section: alien
Installed-Size: 122536
Maintainer: root
Architecture: i386
Version: 7.0.9-2
Config-Version: 7.0.9-2 - ELIMINAR (no dejar la línea en blanco. Unir)
Depends: libatk1.0-0 (>= 1.12.2), libc6 (>= 2.3.6-6), libfontconfig1 (>= 2.4.0), libglib2.0-0 (>= 2.12.0), libglu1-mesa | libglu1, libgtk2.0-0 (>= 2.8.0), libpango1.0-0 (>= 1.14.8), libx11-6, libxext6, libxt6, xlibmesa-gl | libgl1, zlib1g (>= 1:1.2.1)
Description: Adobe Reader for Linux. An application that can view, navigate and print PDF documents.
Adobe Reader puede leer documentos con formato PDF. Adobe Reader también le permite buscar en archivos PDF, buscar archivos PDF en Internet y participar en revisiones de documentos en colaboración.
.
(Converted from a rpm package by alien version 8.64.)

Pulsamos la tecla "i" y modificamos en la línea Status la palabra "half-configured" por "installed" y eliminamos la línea "Config-Version: 7.0.9-2"
Status: install ok installed

Una vez hecho, le damos a la tecla "[ESC]" y en la línea de comandos ":x" para salir y guardar.
Si no sabes utilizar el editor VI, mira éste post:


5. El programa se ha instalado en mi KDE en el menú OFICINA. También podemos ejecutarlo en una terminal tecleando "acroread".

Al entrar nos mostrará otro error que nos dice que no se puede iniciar el plugin PPKLite.api, pero podemos picar en aceptar y nos seguirá funcionando. Al igual que antes, para evitar algún posible fallo lo corregimos así:
# chmod a-x /usr/local/Adobe/Acrobat7.0/Reader/intellinux/plug_ins/PPKLite.api
# ll /usr/local/Adobe/Acrobat7.0/Reader/intellinux/plug_ins/PPKLite.api
-rw-r--r-- 1 root root 10500190 2006-05-08 02:45 /usr/local/Adobe/Acrobat7.0/Reader/intellinux/plug_ins/PPKLite.api


6. Para finalizar, si queremos que al navegar con iceweasel nos muestre los ficheros PDF en el propio navegador, hacemos lo siguiente:
# ln -s /usr/local/Adobe/Acrobat7.0/Browser/intellinux/nppdf.so /usr/lib/iceweasel/plugins/

# ls -l /usr/lib/iceweasel/plugins/
lrwxrwxrwx 1 root root 41 2007-05-10 00:18 libjavaplugin.so -> /etc/alternatives/iceweasel-javaplugin.so
-rw-r--r-- 1 root root 9044 2007-03-21 20:24 libunixprintplugin.so
lrwxrwxrwx 1 root root 55 2007-05-13 07:48 nppdf.so -> /usr/local/Adobe/Acrobat7.0/Browser/intellinux/nppdf.so

Podemos comprobar que está instalado poniendo en la barra de direcciones de iceweasel lo siguiente: about:plugins

Veremos algo así:
Adobe Reader 7.0
Nombre del fichero: nppdf.so
The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
Tipo MIME Descripción Sufijos Activado
application/pdf Portable Document Format pdf
application/vnd.fdf Acrobat Forms Data Format fdf
application/vnd.adobe.xfdf XML Version of Acrobat Forms Data Format xfdf
application/vnd.adobe.xdp+xml Acrobat XML Data Package xdp
application/vnd.adobe.xfd+xml Adobe FormFlow99 Data File xfd

Saludos y Suerte.
Domi - Gran Canaria (Islas Canarias)

8 comentarios:

Anónimo dijo...

Holas! Pues a mi me parece más sencillo bajar la versión *.tar.gz e instalar de ahí. También uso Debian etch y no me ha dado ningún error. Sólo hay que descomprimir y luego ./INSTALL y ya está. Funciona muy bien. Saludos!!

Romario dijo...

Hola. Gracias por compartir tu experiencia. A mi personalmente me gusta más instalar el paquete .deb, por comodidad a la hora de administrar los paquetes. En versiones anteriores que había probado, no me había dado tantos problemas, pero bueno, al final lo he solucionado.

Saludos.

masterLoki dijo...

Y por que el Reader si puedes usar KPDF??

Romario dijo...

Intenta rellenar éste PDF y desgraciadamente, tendrás la respuesta.
http://www.aeat.es/AEAT/Contenidos_Comunes/Modelos_y_formularios/Formularios/Modelos_de_Representacion/repre_2.pdf

Anónimo dijo...

para que tngo que parir o esstresarme si tengo al gran repositorio de debian-multimedia y los todopoderosos paquetes de marillat?
me parece que son cosas innecesarias...

Anónimo dijo...

te apoyo pero te falto la linea...

www.debian-multimedia.org

alli esta adobe reader, ademas si no puedo llenar un formulario tengo derecho a que me den uno llenable por mi os, windows es solo uno de los cientos que existen, y adobe reader solo ta para windows...

replica louis vuitton bags dijo...

fake louis vuitton bags for sale.
cheap louis vuitton antheia for sale.
replica Mahina Leather for sale.
replica Monogram Canvas handbags for sale.
replica Monogram denim handbags for sale.

viagra online pharmacy dijo...

bueno ahora, por dicha se ha facilitado la instalaciòn de programas en Linux, en especial en ubuntu, antes era un tormento, porque había que meterese al shell para hacer toda la configuración y instalación.