18 de septiembre de 2007

Instalar Adobe Reader 8.1.1 en Debian Etch

Hace unos meses publiqué como instalar Adobe Reader 7.09 en nuestra Debian Etch, y recientemente he visto que han sacado una nueva versión para linux (versión 8.1.1). Afortunadamente para los que utilizamos sistemas basados en debian, han empaquetado ésta versión en un .deb a parte de los tradicionales .rpm y tar.gz. La única pega que le he encontrado hasta ahora, es que sólo está disponible en idioma inglés.

A continuación detallo los pasos a seguir para instalar ésta nueva versión.


1. Como siempre, abrimos una terminal (KONSOLE) y nos logueamos como root.

$ su -
password:

#


2. Como anteriormente había instalado la versión de Adobe Reader 7.09 mediante la guía que publique el 13 de mayo, desinstalo el paquete de la siguiente forma: (En caso de que no lo hayas instalado, continúa en el paso 3).

# aptitude purge adobereader-esp
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Leyendo las descripciones de las tareas... Hecho
Construir la base de datos de etiquetas... Hecho
Se ELIMINARÁN los siguientes paquetes:
adobereader-esp{p}
0 paquetes actualizados, 0 nuevos instalados, 1 para eliminar y 0 sin actualizar.
Necesito descargar 0B de ficheros. Después de desempaquetar se liberarán 125MB.
¿Quiere continuar? [Y/n/?] y
Escribiendo información de estado extendido... Hecho
(Leyendo la base de datos ...
98144 ficheros y directorios instalados actualmente.)
Desinstalando adobereader-esp ...
Purgando ficheros de configuración de adobereader-esp ...
dpkg - atención: al desinstalar adobereader-esp, el directorio /usr/local/Adobe/Acrobat7.0/Reader/intellinux/lib'
no está vacío, no se borra.
dpkg - atención: al desinstalar adobereader-esp, el directorio /usr/local/Adobe/Acrobat7.0/Reader/intellinux'
no está vacío, no se borra.
dpkg - atención: al desinstalar adobereader-esp, el directorio /usr/local/Adobe/Acrobat7.0/Reader'
no está vacío, no se borra.
dpkg - atención: al desinstalar adobereader-esp, el directorio /usr/local/Adobe/Acrobat7.0'
no está vacío, no se borra.
dpkg - atención: al desinstalar adobereader-esp, el directorio /usr/local/Adobe'
no está vacío, no se borra.
dpkg - atención: al desinstalar adobereader-esp, el directorio /usr/local'
no está vacío, no se borra.

Como se puede leer en la salida del comando anterior, aptitude no ha podido borrar el directorio /usr/local/Adobe/ y todo su contenido. Lo hacemos manualmente con éste comando.

# rm -Rf /usr/local/Adobe/

Con el parámetro -R, borramos el directorio /usr/local/Adobe de forma recursiva (con todo su contenido) y con el parámetro "f" le decimos que no queremos ir confirmando la eliminación de cada archivo/directorio que vaya encontrando.


3. Accedemos mediante el navegador Iceweasel a la página de descarga de Adobe Reader y bajamos la nueva versión. Para más detalles mira la siguiente imágen:


19.01.08 ACTUALIZACIÓN:
Gracias a un comentario de un usuario en éste post, me he enterado de que ya está disponible la versión en español del paquete .deb de instalación para Debian. Gracias Formiga.


Por defecto si no habéis modificado el directorio de descargas de Iceweasel, nos habrá bajado el paquete a nuestro directorio /home/usuario/Desktop.


4. Instalamos el paquete descargado anteriormente:

Versión en Inglés:
# dpkg -i /home/nombre_de_tu_usuario/Desktop/AdobeReader_enu-8.1.1-1.i386.deb
(Leyendo la base de datos ...
97672 ficheros y directorios instalados actualmente.)
Desempaquetando adobereader-enu (de .../AdobeReader_enu-8.1.1-1.i386.deb) ...
Configurando adobereader-enu (8.1.1) ...

Versión en Español:
# dpkg -i /home/nombre_de_tu_usuario/Desktop/AdobeReader_esp-8.1.1-1.i386.deb
(Leyendo la base de datos ...
97672 ficheros y directorios instalados actualmente.)
Desempaquetando adobereader-enu (de .../AdobeReader_esp-8.1.1-1.i386.deb) ...
Configurando adobereader-esp (8.1.1) ...

5. Para ejecutarlo nos vamos a nuestro MENÚ KDE / OFICINA / Adobe Reader o escribimos en una terminal el comando "acroread".


6. Si quieres añadir el plugin de adobe al navegador Iceweasel para abrir los documentos pdf directamente desde el navegador, ejecutamos el siguiente comando:

# ln -s /opt/Adobe/Reader8/Browser/intellinux/nppdf.so /usr/lib/iceweasel/plugins/


Puedes comprobar que el plugin está correctamente instalado escribiendo en la barra de direcciones de Iceweasel "about:plugins". Debes ver lo siguiente:



7. Solución a éste error:
Si al iniciar el programa os aparece la pantalla siguiente con el error "Unable to find the HTML rendering library (libgtkembedmoz)", el programa nos está pidiendo que le indiquemos la ruta de la librería "libgtkembedmoz.so":


Buscamos la librería en nuestro sistema con el comando siguiente:

# find / -iname libgtkembedmoz.so
/usr/lib/icedove/libgtkembedmoz.so

Si no la encuentras, en el siguiente enlace puedes ver que paquetes dentro de la rama estable, contienen dicha librería. Tendrás que instalar uno de ellos y volver a buscar con el comando anterior.
http://packages.debian.org/search?suite=etch&arch=i386&mode=exactfilename&searchon=contents&keywords=libgtkembedmoz.so

Lo único que tienes que hacer ahora es indicarle la ruta. Abrimos el programa Adobe Reader nos, vamos al menú EDIT / INTERNET y dejámos tal como aparece a continuación.



Saludos y Suerte.
Domi - Gran Canaria (Islas Canarias)

13 comentarios:

Debianés dijo...

Actualmente, siguiendo tus pasos, en la página de Adobe te indican que "Para esta configuración no está disponible una versión de Reader®".

Es más simple y cómodo habilitar el repositorio de www.debian-multimedia.org y luego actualizar e instalar acroread y los paquetes relacionados.

Romario dijo...

Hola Debianés.
En el paso 3, si abres la imagen, verás que descargo el programa en idioma "inglés". Actualmente como dices no existe el paquete en Español.

El repositorio www.debian-multimedia.org es otra opción, pero personalmente me gusta más ésta.

Saludos.
Domi

Anónimo dijo...

Hola que tal:
segui sus pasos pero alfinal me dice que la arquitectura del paquete (i386) no corresponde con la del sistema (amd64) ¿Hay Adobe para amd64?
Gracias

Romario dijo...

Hola. Desconozco si existe paquete de Adobe Reader para Amd64. En la página he visto que no.
Si instalas la versión de Debian de 32 creo que no te dará ningún problema al instalar paquetes compilados para 32 bits, como es el caso.
Siento no poder ayudarte mas.

Saludos.
Domi

piponazo dijo...

Hola! Tan solo darte las gracias, he logrado solucionar el problema con el dichoso libgtkembedmoz ;)

formiga ('')--,--,- dijo...

Ya està disponible la versión en español.


http://www.adobe.com/es/products/acrobat/readstep2_servefile.html?option=full&platform=LINUX_.deb&order=1&type=&esdcanbeused=0&esdcanhandle=0&hasjavascript=1&dlm=&os=linux&winPlatform=&macPlatform=&linuxPlatform=LINUX_.deb&solarisPlatform=&aixPlatform=&hpPlatform=&mobilePlatform=&otherPlatform=&language=Spanish&order_radio=1&buttonDownload=&getgtb=0&getsconly=0

Romario dijo...

Gracias por el aviso.

Saludos.
Domi

Anónimo dijo...

Anduve muy bien con tu guía para instalar el programa. Soy nuevo en esto y la verdad está súper clara. Eso sí ahora tengo que ver cómo meto el plug in pero en Mozilla! Saludos

Artaud dijo...

Genial, solucionado al instante, grazie.

Antonio dijo...

Para instalarlo en la arquitectura AMD64 es de la siguiente manera (a mí me funcionó así):
sudo dpkg -i --force-architecture AdobeReader_esp-8.X.X-X.i386.deb

cambiar las X por la versión actual.

y después instalar la librería siguiente:
sudo apt-get install ia32-libs

que es la que yo creo que hace trabajar al AMD64 como si fuera de 32.

Anónimo dijo...

Faltan las librerias gtk para que corra en amd64:

dpkg -i --force-architecture AdobeReader_esp-8.X.X-X.i386.deb
apt-get install ia32-libs ia32-libs-gtk

replica louis vuitton bags dijo...

fake louis vuitton bags for sale.
cheap louis vuitton antheia for sale.
replica Mahina Leather for sale.
replica Monogram Canvas handbags for sale.
replica Monogram denim handbags for sale.

Pacheta dijo...

dpkg: error processing adobereader-esp (--install):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
adobereader-esp

No me funcionó :( (intentaba hacer los pasos para instalar el adobe en amd64